Исло n(0 меньше =N меньше =9). Составьте программу, вычисляющую сумму всех двухзначных чисел, в записи которых есть цифра N Пж побыстрее!!)))

Исло n(0<=N<=9). Составьте программу, вычисляющую сумму всех двухзначных чисел, в записи которых есть цифра N Пж побыстрее!!)))
Гость
Ответ(ы) на вопрос:
Гость
import java.util.*; import java.lang.*; class Brainly{ public static void main(String[] args){ Scanner sc = new Scanner(System.in); // то для ввода int sum = 0; for(int i = 10; i < 100; i++){ sum += i; }; System.out.print(sum); } }
Гость
var n,s,i:integer; begin write('n = '); readln(n); s:=0; for i:=10 to 99 do  if (i mod 10 = n)or(i div 10 = n)   then s:=s+i; writeln('s = ',s); end. Пример: n = 1 s = 593
Не нашли ответ?
Ответить на вопрос
Похожие вопросы