Известны координаты трех точек. Составить программу нахождения площади треугольника, построенного по этим точкам ПОМОГИТЕ ПОЖАЛУЙСТА
Известны координаты трех точек. Составить программу нахождения площади треугольника, построенного по этим точкам
ПОМОГИТЕ ПОЖАЛУЙСТА
Ответ(ы) на вопрос:
Гость
Program n1;
var x1,x2,y1,y2,x3,y3,S: real;
begin
write('введите координаты точки А: ');
readln(x1,y1);
write('введите координаты точки B: ');
readln(x2,y2);
write('введите координаты точки C: ');
readln(x3,y3);
S:=0.5*((x1-x3)*(y2-y3)-(x2-x3)*(y1-y3));
writeln('площадь: ',abs(S));
end.
Не нашли ответ?
Похожие вопросы