Как Написать программу, которая в последовательности чисел (количество вводится с клавиатуры) определяет сумму чисел, кратных 9 и оканчивающихся на 3.PascalABC.net
Как Написать программу, которая в последовательности чисел (количество вводится с клавиатуры) определяет сумму чисел, кратных 9 и оканчивающихся на 3.
PascalABC.net
Ответ(ы) на вопрос:
var
a: array of integer;
i,n, s: integer;
begin
write('Введите количество чисел: ');
readln(n);
SetLength(a, n);
s:=0;
for i:=0 to n-1 do
begin
write('Введите число', i+1, ': ');
readln(a[i]);
if (a[i] mod 9 = 0) and (a[i] mod 10 = 3) then s:=s+a[i];
end;
writeln;
writeln('Исходный массив:');
for i:=0 to n-1 do write(a[i]:5);
writeln;
writeln('Сумма чисел, кратных 9 и оканчивающихся на 3 = ', s:5);
a:=nil;
end.
Не нашли ответ?
Похожие вопросы