На паскале нужно решить задачи 1.Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого числа. 2.Задано трехзначное число. Составьте программу, с помощью которой определите , р...
На паскале нужно решить задачи
1.Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого числа.
2.Задано трехзначное число. Составьте программу, с помощью которой определите , равняются ли в нем крайние числа.
Ответ(ы) на вопрос:
var
a,e,d,s,p: integer;
begin
p:=1;
writeln ('введи трехзначное число');
read (a);
e:= (a mod 10);
s:=(a div 100);
d:=s*100-e;
p:=s*s*s*d*d*d*e*e*e;
writeln ('произведение кубов цифр числа равно',p);
if e=s then writeln ('первая цифра числа равна последней')
else
writeln ('первая цифра числа не равна последней');
end.
Не нашли ответ?
Похожие вопросы