На Паскале. Вводятся координаты X, Y для N точек. Определите, сколько точек попадают в круг радиуса R. Сколько точек попадают в кольцо с меньшим радиусом R1, большим R2.
На Паскале.
Вводятся координаты X, Y для N точек. Определите, сколько точек попадают в круг
радиуса R. Сколько точек попадают в кольцо с меньшим радиусом R1, большим R2.
Ответ(ы) на вопрос:
Гость
var x,y,R,R1,R2,rt:real;i,N,k,m :integer;begin
R:= 15; R1:= 12; R2:=25;write('Введите N'); Read(N);
for i:=1 to N do beginwrite('Введите координаты х и у'); Read(x,y);rt:=sqrt(sqr(x)+ sqr(y));writeln('r =':3,rt:6);
if rt < R then k:= k + 1;
if (rt < R2) and (rt > R1) then m:= m + 1;
end;writeln; writeln('Количество точек в кругу с радиусом R = ',k);writeln('Количество точек в кольце = ',m);end.
Не нашли ответ?
Похожие вопросы