На вход программе подаётся последовательность символов, заканчивающаяся точкой (

На вход программе подаётся последовательность символов, заканчивающаяся точкой (точка – признак конца и в последовательность не входит). Вывести слово YES, если введённая последовательность является правильной записью нечётного числа в пятнадцатеричной системе счисления, и NO в противном случае.
Гость
Ответ(ы) на вопрос:
Гость
Var   s:string;   i:integer;   r:boolean;   d,d1:set of char; begin   d:=['0'..'9','А','B'..'E'];   d1:=['1','3','5','7','9','B','D'];   Write('Введите строку: '); Readln(s);   r:=True;   for i:=1 to Length(s) do begin     if s[i]='.' then break;     if not (s[i] in d) then begin r:=False; break end     end;   if r then r:=(s[i-1] in d1);   if r then Writeln('YES')   else Writeln('NO') end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы