Надо написать программу Вычислите N! ("эн-факториал") – произведение всех натуральных чисел от 1 до N ( N!=1∙2∙3∙…∙ N ). Входные данные Вводится единственное число N – натуральное, не превосходит 12. Выходные данные Выведите по...
Надо написать программу
Вычислите N! ("эн-факториал") – произведение всех натуральных чисел от 1 до N ( N!=1∙2∙3∙…∙ N ).
Входные данные
Вводится единственное число N – натуральное, не превосходит 12.
Выходные данные
Выведите полученное значение N!
Примеры
входные данные
2
выходные данные
2
входные данные
3
выходные данные
6 (На Паскале) Буду благодарен
Ответ(ы) на вопрос:
Гость
program fact;
var
n, f, i: integer;
begin
f := 1;
readln(n);
for i := 2 to n do
f := f * i;
writeln(f);
end.
Гость
var b,i,k,n: int64;
begin
readln(n);
b:=1;
for i := 1 to n do
b:=b*i;
writeln(b);
end.
Входные данные подставлять в переменную n
Не нашли ответ?
Похожие вопросы