Написать на Паскале Остаток Входные данные Вводятся 4 числа: a, b, c и d. Выходные данные Выведите все числа на отрезке от a до b, дающие остаток c при делении на d. Если таких чисел не существует, то ничего выводить не нужно...
Написать на Паскале
Остаток
Входные данные
Вводятся 4 числа: a, b, c и d.
Выходные данные
Выведите все числа на отрезке от a до b, дающие остаток c при делении на d. Если таких чисел не существует, то ничего выводить не нужно.
Примеры
входные данные
2
5
0
2
выходные данные
2 4
входные данные
2
7
9
14
Ответ(ы) на вопрос:
var
a,b,c,d,i:integer;
begin
writeln('Ввежите значения для a, b, c, d,');
readln(a,b,c,d);
writeln('Результат');
for i:=a to b do
if (i mod d)=c then write(i,' ');
writeln;
end.
Не нашли ответ?
Похожие вопросы