Написать программу для отыскания max(min(a,b), min(c,d)),  не используя сложные логические условия и вложенные ветвления. Числа a,b,c,d - целые. Протестировать программу для следующих исходных данных:а) a=4 b=5 c=6 d=9б) a=2 b=...

Написать программу для отыскания  max(min(a,b), min(c,d)),  не используя сложные логические условия и вложенные ветвления. Числа a,b,c,d - целые. Протестировать программу для следующих исходных данных: а) a=4 b=5 c=6 d=9 б) a=2 b=1 c=6 d=9 в) a=2 b=1 c=8 d=4 г) a=12 b=1 c=6 d=9
Гость
Ответ(ы) на вопрос:
Гость
var a,b,c,d,m1,m2,max:integer; begin write('Введите a,b,c,d: '); readln(a,b,c,d); if a