Написать программу для ряда задач: 1.Найти сумму трех чисел. 2.Катеты прямоугольного треугольника известны.Найти гипотенузу. 3.Найти среднеарифметическое двух чисел. 4.Найти длину окружности,если известна площадь круга. 5.Какой...

Написать программу для ряда задач: 1.Найти сумму трех чисел. 2.Катеты прямоугольного треугольника известны.Найти гипотенузу. 3.Найти среднеарифметическое двух чисел. 4.Найти длину окружности,если известна площадь круга. 5.Какой процент составляет число а от числа b. 6.Найдите площадь треугольника с помощью формулы Герона. 7.Найдите площадь кольца,если его толщина I см,диаметр внутри круга d см. 8.Вычислите площадь треугольника заданного координатами вершин. 9.Вычислить длинны сторон треугольника по заданным координатам его вершин. Зарание спасибо)
Гость
Ответ(ы) на вопрос:
Гость
var     a, b, c, p: real;     a1, b1, c1: real;     a2, b2, c2: real; function SideLength(a1, a2, b1, b2: real): real; begin     SideLength := sqrt(sqr(a1 - b1) + sqr(a2 - b2)); end; begin     writeln('1.Найти сумму трех чисел');     readln(a, b, c);     writeln(a + b + c);          writeln('2.Катеты прямоугольного треугольника известны.Найти гипотенузу.');     readln(a, b);     writeln(sqrt(a * a + b * b));          writeln('3.Найти среднеарифметическое двух чисел.');     readln(a, b);     writeln((a + b) / 2);          writeln('4.Найти длину окружности,если известна площадь круга.');     readln(a);     writeln(sqrt(a / pi) * 2 * pi);          writeln('5.Какой процент составляет число а от числа b.');     readln(a, b);     writeln(a / b * 100);          writeln('6.Найдите площадь треугольника с помощью формулы Герона.');     readln(a, b, c);     p := (a + b + c) / 2;     writeln(sqrt((p - a) * (p - b) * (p - c) * p));          writeln('7.Найдите площадь кольца,если его толщина I см,диаметр внутри круга d см.');     readln(a, b);     c := a + b;     writeln(pi * (c * c - b * b));          writeln('8.Вычислите площадь треугольника заданного координатами вершин.');     readln(a1, a2, b1, b2, c1, c2);     writeln(((a1 - c1) * (b2 - c2) - (a2 - c2) * (b1 - c1)) / 2);          writeln('9.Вычислить длинны сторон треугольника по заданным координатам его вершин.');     a := SideLength(a1, a2, b1, b2);     b := SideLength(c1, c2, b1, b2);     c := SideLength(a1, a2, c1, c2);     writeln(a, ' ', b, ' ', c); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы