Написать программу калькулятор:задаются два числа ,символ арифметической операции(+,-,*,/),вывести результат в виде (5+6=11)
Написать программу калькулятор:задаются два числа ,символ арифметической операции(+,-,*,/),вывести результат в виде (5+6=11)
Ответ(ы) на вопрос:
Program calculator; var a,b:real; x:char; begin write('Введите два числа'); readln(a,b); write('Выберите действие'); readln(x); If x='+' then writeln(a, x, b,'=',a+b); If x='-' then writeln(a, x, b,'=',a-b); If x='*' then writeln(a, x, b,'=',a*b); If x='/' then writeln(a, x, b,'=',a/b); end.
uses crt; var a,b,s:real; z:char;
begin
write('Vvedite A = ');
readln(a);
write(' + - / * : ' );
readln(z);
write('Vvedite B = ');
readln(b);
case z of
'+': begin s:=a+b; writeln(a,' + ',b,' = ',s); end;
'-': begin s:=a-b; writeln(a,' - ',b,' = ',s); end;
'*': begin s:=a*b; writeln(a,' * ',b,' = ',s); end;
'/': begin s:=a/b; writeln(a,' / ',b,' = ',s); end;
else
writeln('error: incorrect operation symbol!!!');
end;
readln;
end.
Не нашли ответ?
Похожие вопросы