Написать программу, которая определяет, попадает ли точка с заданными координатами в область, закрашенную на рисунке серым цветом. Результат работы программы вывести в виде текстового сообщения. Язык c#

Написать программу, которая определяет, попадает ли точка с заданными координатами в область, закрашенную на рисунке серым цветом. Результат работы программы вывести в виде текстового сообщения. Язык c#
Гость
Ответ(ы) на вопрос:
Гость
using System; public class Test { public static void Main() { double r, x, y; Console.Write("r = "); r = double.Parse(Console.ReadLine()); Console.Write("x = "); x = double.Parse(Console.ReadLine()); Console.Write("y = "); y = double.Parse(Console.ReadLine()); if ((y>=0)&&(x*x+y*y<=r*r)||(x<=0)&&(y>=-r)&&(y<=x)) Console.WriteLine("Точка попадает в область"); else Console.WriteLine("Точка не попадает в область"); Console.ReadLine(); } } Пример: r = 3 x = -1 y = -2 Точка попадает в область
Не нашли ответ?
Ответить на вопрос
Похожие вопросы