Написать программу которая принимает с клавиатуры 5-значное число а выводит сумму цифр этого числа пожалуйста срочно очень!!!

Написать программу которая принимает с клавиатуры 5-значное число а выводит сумму цифр этого числа пожалуйста срочно очень!!!
Гость
Ответ(ы) на вопрос:
Гость
program chisla; uses crt; var a,b,c,d,e,f,summa : integer; begin write('Введите пятизначное число '); Readln(a); if (a>99999) or (a<10000) then Writeln('Введено не пятизначное число') else begin b:=a div 10000; c:=(a-(b*10000)) div 1000; d:=(a-(b*10000)-(c*1000)) div 100; e:=(a-(b*10000)-(c*1000)-(d*100)) div 10; f:=a-(b*10000)-(c*1000)-(d*100)-(e*10);summa:=b+c+d+e+f; Writeln(summa); end end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы