Написать программу, которая в последовательности натуральных чисел находит количество чисел, превосходящих 100. На вход программы подаются натуральные числа, не превосходящие 1000, количество их неизвестно и не превышает 3000. ...
Написать программу, которая в последовательности натуральных чисел находит количество чисел, превосходящих 100. На вход программы подаются натуральные числа, не превосходящие 1000, количество их неизвестно и не превышает 3000. Ввод чисел прекращается вводом отрицательного числа (это число в последовательность не входит). Программа должна вывести только одно число – количество чисел, превосходящих 100.
Ответ(ы) на вопрос:
var n, s : integer;
begin
s := 0;
while 2 * 2 <> 5 do begin
readln(n);
if n < 0 then break;
if n > 100 then s := s + 1;
end;
writeln(s);
end.
Не нашли ответ?
Похожие вопросы