Написать программу на любом из яп: pascal,c#,php Боря Лейкин на время каникул устроился работать помощником почтальона. Сегодня ему необходимо доставить телеграмму в квартиру n девятиэтажного дома, в котором несколько подъездов...

Написать программу на любом из яп: pascal,c#,php Боря Лейкин на время каникул устроился работать помощником почтальона. Сегодня ему необходимо доставить телеграмму в квартиру n девятиэтажного дома, в котором несколько подъездов, а на каждом этаже подъезда по четыре квартиры Требуется написать программу, которая по номеру квартиры n выведет номер подъезда и этаж на котором находится эта квартира.
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.Net const   e=9; // этажность дома   k=4; // количество квартир на этаже var   n,pn,c,en:integer; begin   Write('Укажите номер квартиры: '); Read(n);   c:=e*k; // количество квартир в подъезде   pn:=(n-1) div c + 1; // номер подъезда   en:=(n-(pn-1)*c-1) div 4 + 1; // номер квартиры   writeln('Подъезд ',pn,', этаж ',en)  end. Тестовое решение: Укажите номер квартиры: 54 Подъезд 2, этаж 5
Не нашли ответ?
Ответить на вопрос
Похожие вопросы