Написать программу на языке Pascal используя операторы цикла. Задача: Задать случайным образом N [latex](1\leq N \leq 15).[/latex] Напечатать значение N! = 1*2*3*4*...*N
Написать программу на языке Pascal используя операторы цикла. Задача: Задать случайным образом N [latex](1\leq N \leq 15).[/latex] Напечатать значение N! = 1*2*3*4*...*N
Ответ(ы) на вопрос:
Гость
Program n1;
var
n, i: integer;
p: real;
begin
randomize;
n:=random(15)+1;
p := 1;
for i := 2 to n do
p := p * i;
writeln(n, '! = ',p);
end.
Не нашли ответ?
Похожие вопросы