Написать программу на языке Паскаль Дано: а,b,с Найти:S S=SQRT(p(p-a)(p-b)(p-c)) где р=(а+b+c)/2

Написать программу на языке Паскаль Дано: а,b,с Найти:S S=SQRT(p(p-a)(p-b)(p-c)) где р=(а+b+c)/2
Гость
Ответ(ы) на вопрос:
Гость
var a,b,c,s:integer; function f(a1,b1,c1:real):real; var p:real; begin p:=(a+b+c)/2; f:=sqrt(p*(p-a)*(p-b)*(b-c)); end; BEGIN readln(a,b,c); writeln('S=',f(a,b,c):4:2); end.
Гость
var a,b,c,s:real; procedure Pl(var a,b,c,s:real); var p:real; begin; p:=(a+b+c)/2; s:=sqrt(p*(p-a)*(p-b)*(p-c)); writeln(s); end; begin; readln(a); readln(b); readln(c); if (a>=(b+c)) or (b>=(a+c)) or (c>=(a+b)) then begin; writeln('error'); exit; end; Pl(a,b,c,s); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы