Написать программу Паскаль - Вывести на экран элементы , которые больше значения элемента, номер которого введен с клавиатуры

Написать программу Паскаль - Вывести на экран элементы , которые больше значения элемента, номер которого введен с клавиатуры
Гость
Ответ(ы) на вопрос:
Гость
var   arr : array [1..30] of integer;   i, number : integer; begin   //Заполнение массива случайными числами   for i := 1 to 30 do     arr[i] := Random(10000) - 5000;   //---   //Считывание номера элемента и проверка на соответствие условию   write('Введите число: ');   readln(number);   if not (number in [1..30]) then   begin     write('Ошибка. Номер элемента выходит за границу массива');     Exit;   end;   //---   //Вывод массива с учётом условия   for i := 1 to 30 do     if arr[i] > arr[number] then       write(arr[i], ' ');   //--- end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы