Написать программу в PASCAL начисления скидок: если сумма покупки больше 100, то скидка 10%. Если меньше или равна 100, то скидка 5%
Написать программу в PASCAL начисления скидок: если сумма покупки > 100, то скидка 10%. Если меньше или равна 100, то скидка 5%
Ответ(ы) на вопрос:
Гость
var s:real;
begin
write('Сумма покупки = ');
readln(s);
if s>100 then writeln('Скидка = ',s*0.1)
else writeln('Скидка = ',s*0.05);
end.
Пример:
Сумма покупки = 200
Скидка = 20
Гость
program программаначисленияскидок;
var
a: real;
begin
writeln('Введите сумму покупки.');readln(a);
if a > 100 thenwriteln('Предоставляется скидка 10%.')elsewriteln('Предоставлется скидка 5 %.');
end.
Не нашли ответ?
Похожие вопросы