Написать программу в Pascal вычисления сопротивления электрической цепи, состоящей из 2-х параллельно соединенных сопротивлений. (Величина первого сопротивления 15 Ом второго сопротивления 20 Ом)
Написать программу в Pascal вычисления сопротивления электрической цепи, состоящей из 2-х параллельно соединенных сопротивлений. (Величина первого сопротивления 15 Ом второго сопротивления 20 Ом)
Ответ(ы) на вопрос:
Гость
var r1,r2,r:real;
begin
write('Введите значение R1: ');
readln(r1);
write('Введите значение R2: ');
readln(r2);
r:=r1*r2/(r1+r2);
writeln('Общее сопротивление при параллельном включении: ',r)
end.
Гость
var
R1, R2, R: real;
begin
R1 := 15; //readln(R1);
R2 := 20; //readln(R2);
R := 1/R1 + 1/R2;
R := 1 / R;
writeln('Общее сопротивление проводников (', R1, ' и ', R2, ' Ом): ', R:2:6, ' Ом');
end.
Не нашли ответ?
Похожие вопросы