Написать программу в паскаль по алгоритму. Фото внутри
Написать программу в паскаль по алгоритму. Фото внутри
Ответ(ы) на вопрос:
Гость
Var a,b,c,max:real;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
if a>b then
if a>c then max:=a
else max:=c
else
if b>c then max:=b
else max:=c;
WriteLn(max)
End.
Var a,b,c,D:real;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
D:=b*b-4*a*c;
if D>=0 then
Begin
WriteLn('x1 = ',(-b-sqrt(D))/(2*a));
WriteLn('x2 = ',(-b+sqrt(D))/(2*a));
End
else
if c<>0 then WriteLn('Корней нет')
else Write('Любое число')
End.
Не нашли ответ?
Похожие вопросы