Написать программу в паскале:Дано трехзначное число. Найти число, полученное перестановкой первой и третьей цифры заданного числа. 

Написать программу в паскале: Дано трехзначное число. Найти число, полученное перестановкой первой и третьей цифры заданного числа. 
Гость
Ответ(ы) на вопрос:
Гость
var a,b,c,n:integer;beginreadln(n);{находим 1 цифру}a:=n mod 10;b:=n div 10 mod 10 ;c:= n div 100;n:=100*a + 10*b + c;writeln(n);end.
Гость
Другой способ: var a,i:longint; begin readln(a); for i:=1 to 3 do begin write(a mod 10); a:=a div 10; end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы