Написать программу. Ввести последовательность чисел размерностью n. В этой последовательности: найти минимальный и максимальный элементы. среднее арифметическое отрицательных чисел Вывести на экран значения min и max элементов ...

Написать программу. Ввести последовательность чисел размерностью n. В этой последовательности: найти минимальный и максимальный элементы. среднее арифметическое отрицательных чисел Вывести на экран значения min и max элементов и их номера, и среднее арифметическое
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.0, сборка 1088 var   n,i,max,min,s,t,k:integer; begin   Write('Введите количество членов последовательности: ');   Read(n);   Writeln('Вводите числа через пробел');   max:=-32768; min:=32767; s:=0; k:=0;   for i:=1 to n do begin     Read(t);     if tmax then max:=t;     if t<0 then begin s:=s+t; Inc(k) end     end;   Writeln('Min=',min,', max=',max,', ср.арифм.=',s/k:0:5) end. Тестовое решение: Введите количество членов последовательности: 7 Вводите числа через пробел 25 -6 39 -118 271 24 -15 Min=-118, max=271, ср.арифм.=-46.33333
Не нашли ответ?
Ответить на вопрос
Похожие вопросы