Написать программу вычисления стоимости поездки на автомобиле на дачу (туда и обратно). Исходными данными являются: расстояние до дачи (в километрах); количество бензина, которое потребляет автомобиль на 100 км пробега; цена од...
Написать программу вычисления стоимости поездки на автомобиле на дачу (туда и обратно).
Исходными данными являются: расстояние до дачи (в километрах); количество бензина, которое
потребляет автомобиль на 100 км пробега; цена одного литра бензина.
С пояснениями.
Вычисление стоимости поездки на дачу и обратно.
Расстояние до дачи (км) —> 67
Расход бензина (литров на 100 км пробега) —> 8.5Цена литра бензина (руб.) —> 6.5
Поездка на дачу и обратно обойдется в 74.04 руб.
Ответ(ы) на вопрос:
s, r, c, ans: real;
begin
readln(s, r, c); // считываем расстояние, расход, стоимость 1 литра
ans := (s / 100) * r * c * 2;
// формула вычисления стоимости s / 100 - коэффициент затраты его умножаем на расход //на 100 км и умножаем на стоимость - это путь в 1 сторону умножив на 2 получаем путь
//туда обратно.
writeln(ans:0:2); //форматированный вывод ответа с точностью 2 знака после запятой
end;
Не нашли ответ?
Похожие вопросы