Написать программу выводящею матрицу 11111 01110 00100 ...
Написать программу выводящею матрицу 11111 01110 00100 01110 11111
Ответ(ы) на вопрос:
var a:array [1..5,1..5] of integer; i,j:integer; begin for i:=1 to 5 do begin for j:=1 to 5 do begin if ((j>=i) and (i+j<=6)) or ((j<=i) and (i+j>=6)) then a[i,j]:=1 else a[i,j]:=0; write (a[i,j]:3); end; writeln; end; readln; end.
Можно обойтись без массива и этим сэкономить память компьютера. Можно также вывести такую матрицу (в виде песочных часов) любого размера. Для этого нужно только изменить значение n в строке const n=5 Program Pentelemon;
uses crt;
const n=5;
var
i,j:integer;
begin
writeln('*** alphaues is thinking... ***');
writeln('*** OK ***');
writeln();
for i:=1 to n do
begin
for j:=1 to n do
begin
if ((j>=i) and (i+j<=n+1)) or ((j<=i) and (i+j>=n+1)) then
write ('1 ')
else
write ('0 ');
end;
writeln();
end;
end.
Не нашли ответ?
Похожие вопросы