Напишите программу, которая меняет местами первую и последнюю цифру натурального трехзначного числа. (ABC Pascal)

Напишите программу, которая меняет местами первую и последнюю цифру натурального трехзначного числа. (ABC Pascal)
Гость
Ответ(ы) на вопрос:
Гость
var a,chislo,t:longint;  c,nov,posl:integer;  begin  readln(a);  posl:=a mod 10;  chislo:=a;  t:=1;  repeat  a:=a div 10;  t:=t*10;  until a<10;  chislo:=chislo mod t;  chislo:=posl*t+chislo-posl+a;  writeln(chislo);  readln;  end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы