Напишите программу, которая производит обмен згачений переменных x и y, если x больше y. пример входных пример выходных данных данных x больше больше 5 x=6 y больше больше 6. y=...
Напишите программу, которая производит обмен згачений переменных x и y, если x больше y.
пример входных пример выходных
данных данных
x>>5 x=6
y>>6. y=5
x>>6 x=5
y>>5. y=6
Ответ(ы) на вопрос:
Гость
Решение №1
var x,y:integer;
begin
readln(x,y);
if x> y then begin
x:=x+y;
y:=x-y;
x:=x-y;
writeln(x,' ',y);
end.
Тестовое решение:
8 5
5 8
Решение №2
На PascalABC.Net можно сделать проще:
var x,y:integer;
begin
readln(x,y);
if x>y then begin swap(x,y); println(x,y); end;
end.
Не нашли ответ?
Похожие вопросы