Напишите программу которая производит обмен значений переменных x и y больше y ВсеВидеоНовостиКартинкиПокупкиЕщё НастройкиИнструменты Безопасный поиск включен
Напишите программу которая производит обмен значений переменных x и y больше y
ВсеВидеоНовостиКартинкиПокупкиЕщё
НастройкиИнструменты
Безопасный поиск включен
Ответ(ы) на вопрос:
Гость
//написано на (си/си++)
#include
#include
int main(){
setlocale(LC_ALL,"");
int x,y;
std::cout << "Введите x:";
std::cin >> x;
std::cout << "Введите y:";
std::cin >> y;
if (x > y){ /*если x > y то он поменяет их местами*/
std::cout << "x и y поменяны местами\n"
x ^= y;
y ^= x;
x ^= y;
}else{
std::cout << "x и y не поменяны местами\n";
}
std::cout << "x:" << x << " y:" < y;
std::cout << std::endl;
system("pause");
return 0;
}
Не нашли ответ?
Похожие вопросы