Напишите программу, которая выполняет циклический сдвиг части массива, начиная с элемента с номером K и заканчивая элементом с номером M(включительно), влево на R элементов.
Напишите программу, которая выполняет циклический сдвиг части массива, начиная с элемента с номером K и заканчивая элементом с номером M(включительно), влево на R элементов.
Ответ(ы) на вопрос:
var
i,k,m,r,p,j:integer;
a:array[1..10]of integer;
begin
writeln('Массив: ');
for i:=1 to 10 do
begin
a[i]:=random(10);
write(a[i],' ');
end;
writeln;
write('Введите K,M,R: ');
readln(k,m,r);
for i:=1 to r do
begin
j:=k;
p:=a[j];
while j
Не нашли ответ?
Похожие вопросы