Напишите программу на языке Паскаль. ____________________________________________ Скорость лодки в ?
Напишите программу на языке Паскаль.
____________________________________________
Скорость лодки в ??тоячей воде Vл км/ч, скорость течения реки Vр км/ч
(Vр < Vл). Время движения лодки по озеру Т1 ч, а по реке (против течения) —
Т2 ч. Определить путь S, пройденный лодкой.
_________________________________________
Добавлю 10, если будет без ошибок.
Ответ(ы) на вопрос:
Гость
Var v1,v2,t1,t2,s1,s2,so:integer;
begin
v1:=0;
v2:=0;
while (v2>=v1) do begin
writeln('введите скорость лодки');
readln(v1);
writeln('введите скорость течения реки');
readln(v2);
if (v2>=v1) then writeln('введены неправильные данные');
end;
writeln('введите время движения лодки по озеру');
readln(t1);
writeln('введите время движения лодки по реке против течения');
readln(t2);
s1:=v1*t1;
s2:=(v1-v2)*t2;
so:=s1+s2;
writeln('длина общего пути ',so);
end.
Не нашли ответ?
Похожие вопросы