Напишите программу нахождения всех четных чисел,кратных P, в диапазоне от N до М)пожалуйста ребята
Напишите программу нахождения всех четных чисел,кратных P,
в диапазоне от N до М)пожалуйста ребята
Ответ(ы) на вопрос:
Гость
var
n,m,p,i:integer;
begin
write('Введите N,M,P через пробел: ');
readln(n,m,p);
For i:=n to m do
if (i mod p = 0) and (i mod 2 =0) then write(i,' ');
end.
Гость
Вот держи, я даже оформил красиво! Var n,m,p,x,i:integer; Begin Write('Введите N >>> '); Readln(n); Write('Введите M >>> '); Readln(m); Write('Введите P >>> '); Readln(p); Writeln('------------------------------------------'); X:=0; For i:=n to m do If (i mod 2 = 0) and (i mod p = 0) and (i <> 0) then Begin X:=x+1; Writeln(i,' - Чётное и кратно ',p); End; End.
Не нашли ответ?
Похожие вопросы