Напишите программу в паскале, вычисляющую НОД для 5 чисел (12,24,30,36,48)

Напишите программу в паскале, вычисляющую НОД для 5 чисел (12,24,30,36,48)
Гость
Ответ(ы) на вопрос:
Гость
//Pascal ABC.NET v3.1 сборка 1219 function nod(a, b:integer):integer;  begin   while a*b<>0 do     if a>b  then      a:=a mod b      else b:=b mod a;    nod:=a+b;  end;  begin writeln(nod(12,nod(24,nod(30,nod(36,48))))); end. Вывод: 6
Не нашли ответ?
Ответить на вопрос
Похожие вопросы