Напишите программу,которая запрашивает у пользователя ввод чисел,пока не будет нажата цифра "ноль".На экран выводит сумму всех введенных чисел
Напишите программу,которая запрашивает у пользователя ввод чисел,пока не будет нажата цифра "ноль".На экран выводит сумму всех введенных чисел
Ответ(ы) на вопрос:
program numSum;
var inp,sum:longint;
begin
repeat
readln(inp);
sum:=sum+inp;
until inp=0; write('Sum - ',sum); readln;
end.
var a,s:integer;
begin
writeln ('Введите целое число');
a:=1;
while a<>0 do
begin
readln (a);
s:=a+s;
end;
writeln ('Сумма всех введенных чисел = ', s);
end.
Не нашли ответ?
Похожие вопросы