Найти сумму положительных элементов вектора C[15]. Помогите составить программу в pascalabc
Найти сумму положительных элементов вектора C[15].
Помогите составить программу в pascalabc
Ответ(ы) на вопрос:
//Проверил. Да, равно.
//Pascal ABC.NET 3.1 сборка 1219
Const
n=15;
Var
ar:array[1..n] of integer;
i,s:integer;
begin
randomize;
writeln('Array:');
for i:=1 to n do
begin
ar[i]:=random(-10,10);
write(ar[i]:4);
if ar[i]>0 then s:=s+ar[i];
end;
writeln;
write('Result:',s);
end.
Пример работы программы:
Array:
3 -7 0 9 -9 6 -1 0 1 0 -7 9 -9 -5 -8
Result:28
Не нашли ответ?
Похожие вопросы