НУЖНА ПОМОЩЬ. PascalABC Задание№1 Составить программу, которая выводит на экран дни с нулевой температурой. Составить программу, которая выводит на экран дни с минимальной и максимальной температурой. Составить программу, котор...

НУЖНА ПОМОЩЬ. PascalABC Задание№1 Составить программу, которая выводит на экран дни с нулевой температурой. Составить программу, которая выводит на экран дни с минимальной и максимальной температурой. Составить программу, которая выводит на экран дни с одинаковой температурой. Задание№2 "Ввод и обработка прямоугольных массивов" Создайте проект Ж/Д расписание. Проверьте его на работоспособность. Дополните программу следующими функциями: - нахождения номера поезда, который прибывает первым на станцию после 18.00. - Сколько через станцию проходит поездов с номерами в пределах от 50 до 150. - Сколько поездов прибывает на станцию в первую половину суток; - Укажите номера поездов, которые прибывают на 1 платформу. Контролер прибыл на станцию с поездом №, на какую платформу ему нужно перейти, чтобы отправиться далее, не потеряв времени. ЗАРАНЕЕ СПАСИБО
Гость
Ответ(ы) на вопрос:
Гость
Пусть данные о температуре хранятся в массиве Тemp  и количество данных (для определенности равно числу дней в месяце n=30) program Temperatura; const n=30; type Mas = array [1..n] of integer; var A: Mas;      i,  Max, MaxInd, Min, MinInd: integer; begin for i:=1 to n do    A[i]:=-20+random(40);          {Заполняем массив случайными числами} { А  СЮДА  ВСТАВЛЯЕМ ПО ОЧЕРЕДИ БЛОКИ } ReadLn; end. {БЛОК:: Дни с нулевой} for i:=1 to n do    if A[i] =0 tnen WriteLn(' Day Number ' ,i ); {БЛОК:  Дни с MaxTemp и MinTemp} Max:=A[1]; Min:=A[1]; MaxInd:=1; MinInd:=1; for i:=2 to n do    begin      if A[i]>Max then begin                                  Max:=A[i];  MaxInd:=i                                end;      if A[i]