Нужна ваша помощь. Необходимо написать программу в PascalABC и лучше с объяснениями. С?
Нужна ваша помощь. Необходимо написать программу в PascalABC и лучше с объяснениями. С??м не понимаю.
Дано натуральное число. Верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
Ответ(ы) на вопрос:
//PascalABC.NET 3.2 сборка 1318
Var
n,a:integer;
b:boolean;
begin
b:=true; //"флаг", указывающий на результат
readln(a); //вводим цифру
readln(n); //вводим число
while n>0 do //пока число не равно 0
if n mod 10=a then //mod 10 возвращает последнюю цифру числа
begin
b:=false; //если эта цифра равна а, тогда "флаг" меняет своё значение
break; //и выходим из цикла
end
else
n:=n div 10; {иначе посредством div 10 убираем самый правый разряд. Если левый аргумент меньше 10, он вернёт 0 и тем самым завершит цикл}
if b=true then writeln('Да') else writeln('Нет'); {"флаг" остаётся true только если не встретилось совпадений в цикле}
end.
Пример ввода:
3
123
Пример вывода:
Нет
Не нашли ответ?
Похожие вопросы