Очень срочно помогите написать программу! вот задача: Заполнить массив из 12 элементов случайными числами в интервале [-12..12] и выполнить инверсию для каждой трети массива. Пример: Исходный массив: 4 -5 3 10 | -4 -6 8 -10 |...

Очень срочно помогите написать программу! вот задача: Заполнить массив из 12 элементов случайными числами в интервале [-12..12] и выполнить инверсию для каждой трети массива. Пример: Исходный массив: 4 -5 3 10 | -4 -6 8 -10 | 1 0 5 7 Результат: 10 3 -5 4 | -10 8 -6 -4 | 7 5 0 1
Гость
Ответ(ы) на вопрос:
Гость
var   a: array[1..12] of integer;   i: integer; begin   randomize;    for i:=1 to 12 do   a[i]:=random(12+12+1)-12; //Заполнение массива   writeln('Исходный массив: ');    for i:=1 to 12 do     write(' ',a[i],' '); //Вывод исходного массива   writeln(); //Для перехода на следующую строку    writeln('Результат: ');   for i:=4 downto 1 do    write(' ',a[i],' ');   for i:=8 downto 5 do    write(' ',a[i],' ');   for i:=12 downto 9 do     write(' ',a[i],' '); //Обратный цикли для каждой трети  end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы