Описать процедуру вычисления НОД и НОК двух чисел. С помощью этой процедуры составьте программу, которая вычисляет НОД и НОК массива натуральных чисел.
Описать процедуру вычисления НОД и НОК двух чисел. С помощью этой процедуры составьте программу, которая вычисляет НОД и НОК массива натуральных чисел.
Ответ(ы) на вопрос:
// НОД.
int gcd(int a,int b) {
return b?gcd(b,a%b):a;
}
// НОК.
int lcm(int a,int b) {
return a/gcd(a,b) * b;
}
int main() {
int arr[1000];
/*
Тут заполняем массив
.....
.....
*/
for (int i = 0; i < 1000; i+=2){
printf("a=%d , b=%d - gcd=%d, lcm = %d \n",
arr[i], arr[i+1], gcd(arr[i], arr[i+1]) , lcm(arr[i], arr[i+1]));
}
}
Не нашли ответ?
Похожие вопросы