Отношение четных чисел к кратным 5 из промежутка -n до n напишите программу! пожалуйста!!!!! ооочень нужноооо

Отношение четных чисел к кратным 5 из промежутка -n до n напишите программу! пожалуйста!!!!! ооочень нужноооо
Гость
Ответ(ы) на вопрос:
Гость
var n,i,kolCH,kolKR5:integer; begin readln(n); kolCH:=0; //Кол-во четных чисел kolKR5:=0;//Кол-во чисел кратных 5 for i:=-n to n do begin if (i mod 2=0) then //Проверка на четность kolCH:=kolCH+1; if (i mod 5=0) then //Проверка на делимость на 5 kolKR5:=kolKR5+1; end; writeln('Четных чисел=',kolCH,' Кратных 5 чисел=',kolKR5); writeln('Отношение=',kolCH/kolKR5); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы