Pascal ABC, сделайте пожалуйста!!!!! 1. Даны натуральное число n и действительные числа a,b
Pascal ABC, сделайте пожалуйста!!!!!
1. Даны натуральное число n и действительные числа a,b. Составьте программу, которая заполняет одномерный массив последовательности чисел t1, t2,…,tn, где ti=(b-a)/n. Полученный массив вывести на экран.
2. Даны натуральные числа n, a1,..,an. Составьте программу, которая определяет количество членов последовательности a1,..,an, являющихся нечётными числами.
3. Даны натуральные числа n, a1,..,an. Составьте программу, которая определяет количество членов последовательности a1,..,an, Кратных 5 и не кратных 3.
4. Даны натуральные числа n, a1,..,an. Составьте программу, которая определяет количество членов последовательности a1,..,an, с чётными порядковыми номерами и нечётными значениями.
5. Даны натуральные числа n, a1,..,an. Составьте программу, которая вычисляет сумму тех элементов последовательности a1,..,an, которые нечётны и отрицательны
6. Даны натуральные числа n, a1,..,an. Составьте программу, которая вычисляет среднее арифметическое элементов последовательности a1,..,an,
7. Даны натуральные числа n, a1,..,an. Составьте программу, которая находит максимальный и минимальный элементы.
8. Даны натуральные числа n, a1,..,an. Составьте программу, которая находит максимальный и минимальный элементы массива и выводит их порядковые номера.
9. Даны натуральные числа n, a1,..,an (В диапазоне от 0 до 100). Составьте программу, которая находит максимальный и минимальный элементы и выводит среднее арифметическое этих чисел.
10. Даны натуральное число n и последовательность целых чисел a1,..,an. Составьте программу, которая определяет количество пар соседних положительных чисел в данной последовательности.
11. Даны натуральное число n и одномерный массив, состоящий из n элементов. Составьте программу, которая в заданном массиве положительные элементы увеличивает вдвое, а отрицательные заменяет на значения их индексов. Полученный массив вывести на экран.
Ответ(ы) на вопрос:
Гость
1) Program n1;
var n,i:integer;
t:array[1..100] of real;
a,b:real;
begin
readln(n);
readln(a);
readln(b);
for i:=1 to n do
begin
t[i]:=(b-a)/n;
write(t[i],' ');
end;
end.
2) Program n1;
var a:array[1..100] of integer;
n,i:integer;
k:real;
begin
read(n);
k:=0;
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if a[i] mod 2 <> 0 then
k:=k+1;
writeln;
writeln('кол-во нечет. чисел равно ',k,'');
end.
6) Program n1;
var a:array[1..100] of real;
i,n:integer;
s,sr:real;
begin
read(n);
for i:=1 to n do
read(a[i]);
s:=0;
sr:=0;
for i:=1 to n do
s:=s+a[i];
sr:=s/n;
writeln('сред. арифметическое равно ',sr,'');
end.
7) Program n1;
var a:array[1..100] of real;
i,n:integer;
min,max:real;
begin
read(n);
for i:=1 to n do
read(a[i]);
min:=a[1];
for i:=2 to n do
if a[i]<min then
min:=a[i];
max:=a[1];
for i:=2 to n do
if a[i]>max then
max:=a[i];
writeln('максимальный элемент равен ',max,'');
writeln('минимальный элемент равен ',min,'');
end.
8) Program n1; var a:array[1..100] of real; i,n:integer; min,max,nom1,nom2:real; begin read(n); for i:=1 to n do read(a[i]); min:=a[1]; nom1:=1; for i:=2 to n do if a[i]<min then begin min:=a[i]; nom1:=i; end; max:=a[1]; nom2:=1; for i:=2 to n do if a[i]>max then begin max:=a[i]; nom2:=i; end; writeln('максимальный элемент равен ',max,', его номер ',nom2,''); writeln('минимальный элемент равен ',min,', его номер ',nom1,''); end.
9) Program n1; var a:array[1..100] of real; i,n:integer; min,max,s,sr:real; begin read(n); randomize; for i:=1 to n do begin a[i]:=random(100)+1; write(a[i],' '); end; writeln; s:=0; sr:=0; for i:=1 to n do s:=s+a[i]; sr:=s/n; writeln('ср. арифм. = ',sr,''); min:=a[1]; for i:=2 to n do if a[i]<min then min:=a[i]; max:=a[1]; for i:=2 to n do if a[i]>max then max:=a[i]; writeln('максимальный элемент равен ',max,''); writeln('минимальный элемент равен ',min,''); end.
Не нашли ответ?
Похожие вопросы