ПАСКАЛЬ. Составьте программу, которая определяет возможность получения слово "мать" из введённой строки.
ПАСКАЛЬ. Составьте программу, которая определяет возможность получения слово "мать" из введённой строки.
Ответ(ы) на вопрос:
// PascalABC.NET 3.1, сборка 1171 от 15.02.2016
begin
var текст:=ReadlnString('->');
var можно:=True;
foreach var буква in 'мать' do
if Pos(буква,текст)=0 then begin
можно:=False; Break end;
if можно then Writeln('Можно составить слово "мать"')
else Writeln('Нельзя составить слово "мать"')
end.
Тестовое решение:
-> На острове растут пальмы
Можно составить слово "мать"
Не нашли ответ?
Похожие вопросы