Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа

Паскаль составьте программу определения наибольшей цифры в записи данного натурального числа
Гость
Ответ(ы) на вопрос:
Гость
Program prog; uses crt; var x,y:integer; begin clrscr; write ('x = '); readln(x); while abs(x)>0 do begin if abs(x mod 10)>y then y:= abs(x mod 10); x:= x div 10; end;  writeln('Наибольшая цифра чсла = ', y);    end.  
Не нашли ответ?
Ответить на вопрос
Похожие вопросы