Паскаль.Составить программу состоящую из 2х процедур. 1ая это сумма рандомных чисел от 1 до 80 которые кратны 5. 2ая это сумма нечетных, отрицательных чисел Добавил вложения со сделанными задачами без процедур, может поможет...

Паскаль.Составить программу состоящую из 2х процедур. 1ая это сумма рандомных чисел от 1 до 80 которые кратны 5. 2ая это сумма нечетных, отрицательных чисел Добавил вложения со сделанными задачами без процедур, может поможет...
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1416 от 26.03.2017 // Внимание! Если программа не работает, обновите версию! function s1(a:array of integer):=a.Where(x->x mod 5=0).Sum; function s2(a:array of integer):=a.Where(x->x.IsOdd and (x<0)).Sum; begin   var a:=ArrRandom(80,-100,100); a.Println; Writeln;   Writeln('S1=',s1(a),', S2=',s2(a)) end. Пример 81 85 -59 97 98 65 -59 -46 -69 -70 -45 -85 -5 -88 30 -30 -60 33 52 -59 79 70 -40 -51 -5 97 78 11 65 -88 -45 78 -90 90 94 0 6 4 -8 -40 49 19 58 -35 43 9 9 24 -59 73 77 31 -59 81 38 -89 24 92 1 -99 87 31 -10 -82 75 -23 -96 5 -81 -71 65 36 -60 -8 -7 -41 -89 95 7 87 S1=25, S2=-1135
Не нашли ответ?
Ответить на вопрос
Похожие вопросы