Получить массив N=10 из следующих чисел [-15; 15].Посчитать сумму элементов, которые за?
Получить массив N=10 из следующих чисел [-15; 15].Посчитать сумму элементов, которые за??анчиваются на 5 и на 8.
Помогите пожалуйста составить программу.
Ответ(ы) на вопрос:
Гость
Var b,sum:integer;
a :array [0..31] of integer;
begin
sum:=0;
randomize;
for b:=0 to 9 do begin
a[b]:= random(31)-15;
writeln(a[b]);
if (abs( a[b] mod 10) = 5) or (abs (a[b] mod 10) = abs(8)) then sum:=sum+a[b];
end;
writeln('сумма элементов оканчивавшихся на 5 или 8 = ',sum)
end.
Не нашли ответ?
Похожие вопросы