Помогите написать программу по информатике (на паскале) на перевод из десятичной системы счисления в двоичную.
Помогите написать программу по информатике (на паскале) на перевод из десятичной системы счисления в двоичную.
Ответ(ы) на вопрос:
Гость
program todec;
uses crt;
function detob(x:integer):string;
var s:string;
begin
s:='';
while x>0 do
begin
s:=chr(ord('0')+x mod 2)+s;
x:=x div 2;
end;
detob:=s;
end;
var a: integer;
begin
clrscr;
writeln('Введите число:');
readln(a);
writeln('Полученное число:',detob(a));
readln;
end.
Не нашли ответ?
Похожие вопросы