Помогите написать программу в Паскале ..... Дано трехзначное число х найти сумму его цифр, среднее арифметическое и записать число в обратном порядке.

Помогите написать программу в Паскале ..... Дано трехзначное число х найти сумму его цифр, среднее арифметическое и записать число в обратном порядке.
Гость
Ответ(ы) на вопрос:
Гость
var   m,n,n1,n2,n3,n4:integer; begin   Write('Введите трехзначное натуральное число: ');   Readln(n);   n1:= n mod 10;   n2:= (n mod 100) div 10;   n3:= n div 100;   m:=n1+n2+n3;   Write('сумма цифр: ',m);   Write('среднее арифметическое: ',m/3);   m = 100*n1 + 10*n2 + n3;   Writeln(' в обратном порядке: ',m) end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы