Помогите написать программу в Паскале и блок-сxему.Задача: ввести 10 чисел, если число положительное, то от него отнять 0,5, если число отрицательное, то ничего с ним не делать. Вывести результат на экран.
Помогите написать программу в Паскале и блок-сxему.
Задача: ввести 10 чисел, если число положительное, то от него отнять 0,5, если число отрицательное, то ничего с ним не делать. Вывести результат на экран.
Ответ(ы) на вопрос:
var a,b,i: real;
begin
b:=0,5;
for i = 1 to 10 do
begin
readln (a);
if a<0 then
writeln (a)
else
a:=a-b;
writeln (a);
end;
end.
Не нашли ответ?
Похожие вопросы