Помогите написать программу)))Задано трехзначное число, определить:1) сумму цифр этого числа;2) произведение;3) минимальную цифру;4) максимальную цифру этого числа.

Помогите написать программу))) Задано трехзначное число, определить: 1) сумму цифр этого числа; 2) произведение; 3) минимальную цифру; 4) максимальную цифру этого числа.
Гость
Ответ(ы) на вопрос:
Гость
uses crt; var a,b,c,x,max,min,sum,pr: integer; begin      write('Введите число:  ');      readln(x);      a:= x div 100;      b:= x div 10 mod 10;      c:= x mod 10;      sum:=a+b+c;      pr:=a*b*c;      if a>b then begin         min:=b;         max:=a;      end      else begin           max:=b;           min:=a;      end;      if min>c then min:=c;      if max
Не нашли ответ?
Ответить на вопрос
Похожие вопросы