Помогите, нужно в системе паскаль написать программу которая запрашивает 5 чисел и сообщает каких больше-положительных или отрицательных
Помогите, нужно в системе паскаль написать программу которая запрашивает 5 чисел и сообщает каких больше-положительных или отрицательных
Ответ(ы) на вопрос:
Гость
var a,b,bz,sz: integer;
begin
b:=0;
bz:=0;
sz:=0;
while (b<5) do begin
write('введите число ==> ');
readln(a);
if (a>0) then bz:=bz+1;
if (a<0) then sz:=sz+1;
b:=b+1;
end;
if bz>sz then writeln('больше положительных');
if sz>bz then writeln('больше отрицательных');
if sz=bz then writeln('число отрицательных и положительных одинаково');
end.
Не нашли ответ?
Похожие вопросы