Помогите пожалуйста. Надо написать программу на паскале: Имеется массив A из N целых чисел, массив B из M целых чисел . Составить массив С из N+M целых чисел , таких, что вначале идут числа массива A , а затем числа массива B.
Помогите пожалуйста. Надо написать программу на паскале:
Имеется массив A из N целых чисел, массив B из M целых чисел . Составить массив С из N+M целых чисел , таких, что вначале идут числа массива A , а затем числа массива B.
Ответ(ы) на вопрос:
program test;
var a: array of integer; b: array of integer; c: array of integer; aa, bb, cc: integer;
begin writeln('Введите размер массива a'); readln(aa); writeln('Введите размер массива b'); readln(bb); a := new integer[aa]; b := new integer[bb]; c := new integer[aa + bb]; cc := 0; aa := 0; bb := 0; writeln('Заполнение массива a'); while(aa < Length(a)) do begin readln(a[aa]); aa := aa + 1; end; writeln('Заполнение массива b'); while(bb < Length(b)) do begin readln(b[bb]); bb := bb + 1; end; while(cc < Length(c)) do begin if(cc < Length(a)) then begin c[cc] := a[cc] end else begin c[cc] := b[cc - Length(a)]; end; cc := cc + 1; end; writeln('Полученный массив'); cc:=0; while(cc < Length(c)) do begin writeln(c[cc]); cc:=cc+1; end;end.
Не нашли ответ?
Похожие вопросы